
Sync-N-Link for FCP
Sync-N-Link for FCP takes away the time-consuming chore of synchronizing dailies or 
rushes by processing projects or bins of unsynchronized clips exported as XML from 
Final Cut Pro. It supports two different workflows:

• Pre-edit sync – Bins of video clips are synced to audio before editing;

• Cut first, sync later – an edited Sequence with camera audio has the audio 
replaced with the full audio tracks.

Please use Provide Feedback… under the application menu for bug reports, feature 
requests or support.
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Organizing Bins and Clips
Sync-N-Link for FCP looks for audio whose free-run Timecode 
matches a video clip’s Timecode (although a matching video and 
audio clip don’t have to start at the same time, have the same 
duration, or even have the same frame rate). A multi-day shoot can 
produce many clips with similar Timecode.
Sync-N-Link for FCP will use the bin organization of clips in Final Cut 
Pro’s Browser window to find the right audio clip: it matches to the 
audio clip closest to the video clip in your bin structure, even if other 
audio clips have similar Timecode. 
For example, a video clip in the bin “Day 1” (or any sub-bins of “Day 
1”) will be matched with an audio clip in “Day 1” in preference to an 
audio clip with similar Timecode in the bin “Day 2.”
You’re probably organizing your bins in a similar way already. 
Without this organization, Sync-N-Link for FCP will not be able to 
choose the right replacement audio.



Syncing Bins of Clips before editorial
Send Sync-N-Link for FCP bins of video and audio clips, and get back merged clips in 
the same bin structure

1. Import the video files and audio files (polyphonic or monophonic BWF, WAV, 
etc.) into Final Cut Pro. Video and audio files must have matching free-run 
Timecode (in either Source, Aux 1, Aux 2 or Sound Timecode fields).

2. Organize the clips into a bin structure – for example by shot, by scene, or by 
day. (See Organizing Bins and Clips for details.)

3. Select the Bins in the Browser window. Choose 
the File menu and from the Export submenu, 
select XML... The dialog will confirm the 
number of Bins and Clips to be exported. 
Name and save the XML file. 
Tip: To reduce processing time, select only the 
Bins of video and audio clips you want to sync 
by Command-clicking on each Bin. 

4. In Sync-N-Link for FCP, click the Open XML... button and select the 
exported XML file, or drag-and-drop the XML file to the dock tile.

5. If your video footage has a camera audio tracks, you can choose whether to 
keep these tracks by using the Keep camera audio checkbox. This checkbox 
will be disabled if there are no camera audio tracks.

6. You can also choose how the merged clips are trimmed. Choosing Trim to 
full duration of video will create a merged clip trimmed to the video 
portion, creating a split edit if the synced audio is shorter than the video; 
choosing Trim to common video and audio duration will create a merged 
clip trimmed to the area where there is both video and audio; and choosing 
No Trim will not set In and Out points.
NOTE: Premiere Pro CC does not support trimmed clips in XML.

7. Choose whether to add log notes (Good, Description, Scene, Shot/Take, Log 
Note, Master Comment 1, Master Comment 2, Master Comment 3, Master 
Comment 4, Comment A and Comment B) from the video or audio clips to 
the merged clips.

8. Click the Sync Bin Clips... button to start the process of finding replacement 
audio. Sync-N-Link for FCP will tell you to how many clips it found 
replacement audio for, how many it didn’t, and gives you the option to save 
a report of the details (see About the Sync-N-Link Report).

9. In the Save dialog, name your XML file and choose a place to save it.
10.In Final Cut Pro, choose the File menu and from the Import submenu, select 

XML... Select the XML file saved out of Sync-N-Link for FCP. (Or use the 
Import automatically after saving checkbox to import the file for you.) 

The clips will be imported into the project in new bins organized into the same bin 
structure as the unsynced clips. Synced clips will be named according to your 
preference (see Preferences for details).



NOTE: We do not expect any errors on import or syncing beyond the known issues. If 
you get an error message from Sync-N-Link for FCP or Final Cut Pro, please email the 
problem XML file to techsupport@intelligentassistance.com.

Syncing Bins of Multiclips before editorial
Send Sync-N-Link for FCP bins of video and audio clips, and get back multiclips in the 
same bin structure

1. Import the video files and audio files (polyphonic or monophonic BWF, WAV, 
etc.) into Final Cut Pro. Video and audio files must have matching free-run 
Timecode (in either Source, Aux 1, Aux 2 or Sound Timecode fields).

2. Organize the clips into a bin structure – for example by shot, by scene, or by 
day. (See Organizing Bins and Clips for details.)

3. To get the multiclip’s camera angles in the right order, Sync-N-Link for FCP 
will use the clip’s angle. If there’s no angle set, the bin should be sorted by 
Name (which is Final Cut Pro’s 
default). Sorting by name means a 
clip named A001_Sc1_Tk1 will become the first angle because it is listed in 
the bin before B001_Sc1_Tk1. Similarly a clip named Sc1_Tk1_Cam1 will be 
angle 1 and Sc1_Tk_1_Cam2 will be angle 2.

4. Select the Bins in Final Cut Pro’s Browser window. Choose the File menu and 
from the Export submenu, select XML... The dialog will confirm the number 
of Bins and Clips to be exported. Name and save the XML file. 
Tip: To reduce processing time, select only the Bins of video and audio clips 
you want to sync by Command-clicking on each Bin. 

5. In Sync-N-Link for FCP, click the Open XML... button and select the 
exported XML file, or drag-and-drop the XML file to the dock tile.

6. Click the Make multiclips checkbox “on” and set the number of camera 
angles in the popup menu.
Note: If you chose to make multiclips using 4 camera angles, but for some 
takes only have 3 angles recorded, then the software will make a multiclip 
with 3 angles. Similarly, if there’s only one video clip for a take, the software 
will make a normal merged clip instead of a multiclip.

7. Click the Sync Bin Clips... button to start the process of finding replacement 
audio. Sync-N-Link for FCP will tell you to how many clips it found 
replacement audio for, how many it didn’t, and gives you the option to save 
a report of the details (see About the Sync-N-Link Report).

8. In the Save dialog, name your XML file and choose a place to save it.
9. In Final Cut Pro, choose the File menu and from the Import submenu, select 

XML... Select the XML file saved out of Sync-N-Link for FCP. (Or use the 
Import automatically after saving checkbox to import the file for you.) 

The multiclips and/or merged clips will be imported into the new project and 
organized into the same bin structure as the unsynced clips, ready for online editorial. 
Multiclips will have the phrase “Synced Multiclip” in their name, while the merged clips 
will named according to your preference (see Preferences for details).
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Syncing Clips in a Sequence after editorial
Send Sync-N-Link for FCP a sequence and bins of video and polyphonic audio clips, and get 
back the sequence with new audio tracks showing the full set of channels from the recording.

1. Import the video files and audio files (polyphonic BWF, WAV, etc.) into Final 
Cut Pro. Video and audio files must have matching free-run Timecode (in 
either Source, Aux 1, Aux 2 or Sound Timecode fields).

2. Organize the clips into a bin structure – for example by shot, by scene, or by 
day. (See Organizing Bins and Clips for details.)

3. Edit your sequence so that the camera audio clips are on the highest audio 
tracks, and non-camera audio clips are on separate tracks below this. Sync-
N-Link for FCP will disable the camera audio tracks you choose and add new 
polyphonic audio tracks above them. 

4. If you've used multiclips in your edit, select all clips in the sequence and 
from the Modify menu choose Collapse Multiclip(s).

5. After you’ve edited your Sequence, select the 
Bins and Sequence you want to use in Final Cut 
Pro’s Browser window. Choose the File menu 
and from the Export submenu, select XML... 
The dialog will confirm the number of Bins, 
Clips and Sequences to be exported. Name and 
save the XML file.
Tip: To reduce processing time, select only the 
Sequence and Bins of video and audio clips 
you want to sync by Command-clicking on each item.
NOTE: We strongly recommend that you include both video and audio clip 
Bins in your exported XML file so that Sync-N-Link for FCP can use your bin 
structure to find the most appropriate audio clip (see Organizing Bins and 
Clips for details).

6. In Sync-N-Link for FCP, click the Open XML... button and select the 
exported XML file or drag-and-drop the XML file to the application icon or 
dock tile.

7. Set your preferences for syncing clips in the Preferences window (see 
Preferences for details).

• Choose the Timecode you want to use for syncing video and audio: either 
Source TC, Aux TC 1, Aux TC 2 or Sound TC.

8. Select the camera audio tracks you want to replace from the pop-up menu. 
These will remain in the sequence as disabled tracks. 

9. Click the Sync Sequence Clips... button to start the process of finding 
replacement audio. Sync-N-Link for FCP will tell you to how many clips it 
found replacement audio for, how many it didn’t, and gives you the option to 
save a report of the detailed information (see About the Sync-N-Link 
Report).



10.In the Save dialog, name your Final Cut Pro XML file and choose a place to 
save it.

11.In Final Cut Pro, choose the File menu and from the Import submenu, select 
XML... Select the XML file saved out of Sync-N-Link for FCP. (Or use the 
Import automatically after saving checkbox to import the file for you.) The 
new Sequence will import into the project. Any audio transitions, effects and 
filters you’ve added to the camera audio tracks will be applied to the new 
polyphonic audio tracks.

NOTE: We do not expect any errors on import or syncing beyond the known issues. If 
you get an error message from Sync-N-Link for FCP or Final Cut Pro, please email the 
problem XML file to techsupport@intelligentassistance.com.

Adjusting the Audio Offset
In cases where the video and audio are out of sync by a few frames, you can apply an 
adjustment to the audio offset.

1. With the clip to adjust in the timeline, Option-drag over the polyphonic 
audio tracks to select them.

2. Either drag the audio tracks or type an offset value (a negative number will 
slip the audio to the left; a positive number will slip the audio to the right) to 
move the polyphonic audio tracks.

3. Once the video and audio are visually in sync, an out-of-sync indicator will 
appear in the video and audio tracks (because the timecode is now out of 
sync). The number displayed in the polyphonic audio track’s out-of-sync 
indicator is the offset value to use. In the example pictured the offset value 
is -2.

4. In Sync-N-Link for FCP, enter the offset value into the Adjust audio offset 
entry box.

5. Click the Sync Bin Clips… or Sync Sequence Clips… button to redo the 
synchronization with the offset applied to each audio clip.
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Preferences
Choose the Sync-N-Link for FCP menu and select Preferences to open the 
Preferences window.

Timecode
You can sync video and audio using a 
combination of Source TC, Aux TC 1, Aux 
TC 2 or Sound TC timecodes. Use the 
separate Video and Audio radio buttons 
to choose which timecode to use for each. 
(Sound TC is only available for Final Cut 
Pro 7.)

Bin Clips
Sync-N-Link for FCP will create new bins 
(based on the original bin structure) that 
end with “Synced” for the new merged 
clips. If you want to include all video clips 
in these bins, change the preference to 
Add all video clips to new bin(s).
You can choose to have the merged clips 
named after the video or audio clip 
names. You can also have the word 
"Synced" appended to the names of the 
merged clips.

Updates
Use the Check at Launch checkbox to 
choose whether to automatically check for 
software updates. You can manually check 
for software updates by clicking the 
Check now button, or by choosing the 
Sync-N-Link for FCP menu and selecting 
Check for Updates…
Checking for software updates occurs only 
when you are connected to the internet.
The latest version of Sync-N-Link for FCP 
can also be downloaded from any internet-connected computer by visiting 
www.AssistedEditing.com/downloads.

http://www.AssistedEditing.com/downloads/
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About the Sync-N-Link Report
Sync-N-Link for FCP can create a detailed 
report about the clips it was able to sync 
and those that weren’t synced. You can 
save this report as a text file by clicking the 
Save Report button. Sync-N-Link for FCP 
will save the report text file and then save 
the XML file.

The top of the report summarizes how many clips had no timecode, how many video 
clips had matching audio found for them, and how many video clips did not have 
matching audio.

Underneath the summary are listed the details for each clip without timecode. 
Example:
! Video Clip "B060_C001_072920_M" in Bin "08Y07M29" has no timecode in the file

Next are listed the details of the video clips that were synced with audio. Example:
! "A013_C002_0803FG_H" in bin "r3d" was synced with "Z004002.WAV" in bin "audio"

Lastly is a list of video clips that were not synced to audio. There are several reasons 
why matching audio may not be found for a video clip.

• If there was no audio captured during a take, Sync-N-Link will report that it was 
unable to find audio for the video clip. Example:

! Could not find audio for "A004_C001_0803DV_H" in bin "Day4"

• If you have audio clips from around the same time of day on two or more days in the 
same bin, Sync-N-Link will not be able to decide which day's audio clip is the right 
match. See Organizing Bins and Clips for details about avoiding this problem. 
Example:

! Found 2 audio clips for "A001_C002_0501GY" in bin "Day1" (unable to choose between 
X0002F.WAV and X0005F.WAV)



Known Issues
Video and audio are in timecode sync, but are visually out of sync by varying amounts.
This can happen when there's a problem with the audio clip's timecode, either when it 
was recorded or on capture into Final Cut Pro. Sync-N-Link for FCP uses the same 
process to line up video and audio timecode as Final Cut Pro's Merge Clip function. 
1. In Final Cut Pro's Browser, select a video and an audio clip that you know should 

sync together.
2. Choose the Modify menu and select Merge Clips…
3. Play the merged clip in the Viewer.
If the merged clip is visually out of sync, then the synced clips produced by Sync-N-Link for 
FCP will also be out of sync because there's a problem with the timecode in the audio clip.

Automatically reconnecting media in Final Cut Pro during an XML import can 
sometimes give unexpected results, such as:

• incorrect clip duration;

• deleted camera audio tracks reappear;

• “General Error” and “Error: Out of Memory” warnings.
Manually reconnecting media seems to provide more reliable results. 

1. When importing XML into Final Cut Pro, the 
Import XML dialog is presented. Deselect the 
Reconnect to Media Files checkbox and click 
OK. Bins of offline clips will be added to the 
project.

2. To manually reconnect the media, select all the 
offline clips in the Bins. Choose the File menu 
and select Reconnect Media. The Reconnect 
Files dialog opens.

3. Use the Locate... or Search... buttons to find your 
media.

Multiple mono BWF audio files
For syncing clips in bins, Sync-N-Link can create 
merged clips from video linked to multiple mono audio 
with matching timecode provided each clip starts and ends on the same timecode. 
Multiple monos are not supported for syncing clips in an edited sequence. However 
WaveAgent from Sound Devices (free) can convert your multiple mono files to 
polyphonics before syncing.
http://www.sounddevices.com/products/waveagent.htm

http://www.sounddevices.com/products/waveagent.htm
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Activating Sync-N-Link for FCP
Sync-N-Link for FCP runs in a demo mode (limited to syncing 10 clips) until it is 
activated with a Serial Number. Each serial number can be used to activate only one 
computer at a time. If you want to activate the software on another computer, you’ll 
need to deactivate it first. See Moving Sync-N-Link for FCP to another computer for 
details.
You’ll temporarily need internet access for the activation so that the software can 
connect to our server and confirm the serial number.

• When the software is first run it will display a Software License Agreement. 
Scroll down to read through the license agreement and click the I Agree 
button at the bottom of the page.

• Enter the Serial Number that was given to you and click the Activate button. 
The software will send the serial number to our server for confirmation.

• You’ll get a message in green saying that you’ve successfully activated your 
license. Click the Continue button.

If the software could not be activated with the Serial Number, you’ll get a message in 
red explaining the reason, such as:

• This is not a valid Serial Number — check to make sure you have entered the 
serial number correctly;

• This is not a Serial Number for Sync-N-Link for FCP — make sure you’re 
entering a serial number that can be used to activate Sync-N-Link for FCP;

• The Serial Number has already been activated — if you want to activate Sync-
N-Link for FCP on this computer you’ll need to deactivate the other installation 
before activating this one, or purchase another serial number.

Moving Sync-N-Link for FCP to another computer
To move Sync-N-Link for FCP from one computer to another, you’ll deactivate it on the 
first computer, then activate the installation on the second computer.
To deactivate the software on one computer and activate it on a different computer, 
both computers will temporarily need internet access.

• On the first computer, choose Deactivate from the application menu.

• Confirm that you want to deactivate the software by clicking the Deactivate 
button.

• You’ll receive a message in green saying that you’ve successfully deactivated 
your license.

• On the second computer, run Sync-N-Link for FCP, and follow the instructions 
for Activating Sync-N-Link for FCP.


